Kamis, 23 Juni 2016

RE: [MS_AccessPros] Re: subform design time issue

 

Hey Bill,  I am trying to decompile yet again.  An issue is that I have to have a local copy of Access and our network is so slow that It isn't responding right now.

 

I had a subform on a form – although a very complicated one – several tabs with a few subforms and command buttons…  I got into design mode and clicked the button to try to put it on the subform and it took so long I was finally able to abort it by ctrl-shift-break.  When I closed that, and opened just the subform, the button went immediately on.

 

Of course this can't be submitted as a help desk ticket because the official stance from corporate is that they don't support Access Databases.  ;-)

 

From: MS_Access_Professionals@yahoogroups.com [mailto:MS_Access_Professionals@yahoogroups.com]
Sent: Thursday, June 23, 2016 2:13 PM
To: MS_Access_Professionals@yahoogroups.com
Subject: RE: [MS_AccessPros] Re: subform design time issue

 



Liz

 

Something else is going on. It might be Citrix but I haven't seem this reported anywhere. Have you tried importing everything into a new, blank database?

 

It could also be that your network connection needs to be looked at. What about doing what I do when developing? I have a dev back end in a local folder and connect to those tables. That way there are no network connections involved.

 

Any changes I make that need to go into prod are exported to a local "prod" ACCDB/MDB that I use to make my ACCDE/MDE. That "prod" has it's tables linked to the prod back end.

 

-Bill



---In MS_Access_Professionals@yahoogroups.com, <liz_ravenwood@beaerospace.com> wrote :

Hello Bill, I decompile quite regularly, and it doesn't seem to make any difference.  The record sources can be simple tables too. 

Thanks though. 

 

From: MS_Access_Professionals@yahoogroups.com [mailto:MS_Access_Professionals@yahoogroups.com]
Sent: Thursday, June 23, 2016 8:41 AM
To: MS_Access_Professionals@yahoogroups.com
Subject: [MS_AccessPros] Re: subform design time issue

 



Liz

 

I've seen this slowdown when working with complex queries as RecordSources. Just to test, remove the RecordSources from the subs and move through the forms. If the slowness is gone then the problem lies in the fact that Access actually re-queries the subs with every focus change. Annoying but that's life.

 

One thing you might try is to decompile the database. Instructions here at FMS. Then compact. Then open your recordsource queries and make a little change. Save them. Undo your changes and save again. This forces Access to re-compile the queries.

 

I don't know if any of that will help you but I've used that technique in the past and it helped quite a bit.

 

Regards,

Bill Mosca, Founder - MS_Access_Professionals

Microsoft Office Access MVP

My nothing-to-do-with-Access blog

 



---In MS_Access_Professionals@yahoogroups.com, <liz_ravenwood@beaerospace.com> wrote :

Does anyone including Microsoft understand how painstaking slow it is to move from subform to subform in design mode?  Is it just me?  Is it because I'm running it within Citrix?

I've worked these databases for 10 years and it was slow with 2002, slower with 2007, and even slower with 2010.  It takes sometimes as long as 5-10 minutes for the control to get the focus and display the properties with which to work.

 

Respectfully,

Liz Ravenwood

Programmer / Analyst

B/E Aerospace | Super First Class Environments

 

<clip>





This email (and all attachments) is for the sole use of the intended recipient(s) and may contain privileged and/or proprietary information. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.






This email (and all attachments) is for the sole use of the intended recipient(s) and may contain privileged and/or proprietary information. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

__._,_.___

Posted by: Liz Ravenwood <Liz_Ravenwood@beaerospace.com>
Reply via web post Reply to sender Reply to group Start a New Topic Messages in this topic (8)

Have you tried the highest rated email app?
With 4.5 stars in iTunes, the Yahoo Mail app is the highest rated email app on the market. What are you waiting for? Now you can access all your inboxes (Gmail, Outlook, AOL and more) in one place. Never delete an email again with 1000GB of free cloud storage.


.

__,_._,___

Tidak ada komentar:

Poskan Komentar